Cannot upload CSV or JSONLines To Autotrain

Ive tried for about 3 hours to upload training data to Huggingface Autotrain and i used this video - Train tabular models automatically with Hugging Face AutoTrain - YouTube

It is now irrelevant as the autotrain is looking for some format that doesnt exist.

I have tried uploading a CSV and JSONL formatted dataset and I get this error- Error type: ValidationError
Details: Can’t split automatically: Invalid number of samples for label “10am EST”, “upcoming monday through Wednesday” in column ‘target’. Auto-splitting requires at least 2 samples for each label, but “10am EST”, “upcoming monday through Wednesday” only has 1 samples

Every target column has at least 2 examples in them, which is not mentioned in the above video. I have formatted that column about 6 different ways to no avail:

Please someone tell me, what needs to be done here? I have tried this target table formats:

  • [tuesday at 5, tuesday 5pm]
  • tuesday at 5, tuesday 5pm
  • [“tuesday at 5”, “tuesday 5pm”]
  • “tuesday at 5, tuesday 5pm”
  • “tuesday at 5”, “tuesday 5pm”

i have also tried multiple target columns… must be glitchy with the auto-splitter?

Thanks - Jon

Can you share more details on the project as in which task and the id/name so that we can investigate further? you can share on autotrain [at] hf [dot] co. Sharing data would make things much easier, if possible.

@abhishek im also having the same issue. JSONL file, with 5 entries, just gets stuck on the “Loading your file” with the browser developer tools reporting a javascript error: caught (in promise) TypeError: Cannot read properties of undefined (reading ‘length’)
at i.$$.update (index.svelte-ba862b8c.js:87:1327)
at zt (index-85986195.js:4:2680)
at yt (index-85986195.js:4:2444)