Can't create endpoint for private model

Hi Team,

I am trying to create a protected inference endpoint for a private model but I am getting this error:
“Private models can only be used within the same organisation”

I’m not quite sure what the issue is since I am not trying to create it outside of the organisation.
I have recently noticed bugs on the free tier (Inference API) too that seem to be related to private models


Happy to provide any more information to replicate. Browser is Chrome, I tried both Azure and AWS and same error. The model is a Wav2Vec2.

Any assistance would be greatly appreciated.

It seems like that you are trying to deploy a private model (repository) from a user or organization where you don’t have access to with the current user in inference endpoints.

My user does have access to it though.

EDIT: I have identified the problem. When viewing the model in the hub and clicking on the “Deploy” it autopopulates a page with details for the model. However, it was using my own user, rather than deploying using the organisation. I switched to the organisation and was able to create the model.

That said, given I have access to the model (I am the owner of the organisation) I’m surprised it didn’t work - or at least, the error message or UX could be clearer

I am also facing this issue, just regarding the solution could you clarify what you mean by switched to the organisation?
EDIT: Follow the solution outlined here