Can't Enter Client Token in Anaconda Prompt

Same issue here. I see the token prompt, but it ignores any inputs and copy-paste. Simply keeps the space blank.

1 Like

Same issue here and tried your suggestion, but does not help.

I did a quick & dirty fix. The command in file that doe not do its job properly is getpass()

1 Like

For some reason the prompt sometimes clears the clipboard copied text.
In anaconda you can paste by right-clicking in the field. Discovered this by accident.
So just copy the key, right-click in the text field and press enter. The text won’t show.

1 Like

How do I fix this issue as I would like to be able login and use the model’s??


login with admin and spent 30min trying this method with no success. I give up! I really want to use AI but this Broken login method is driving me mad! sorry for my out burst. is there any other way with out using adaconda or is this bug across the board?

Im having the same issue I just cant enter the token or anything

that worked!!! TY

Had this same problem, my clipboard was getting cleared after every attempt to login. also, i couldn’t see the text after pasting. Order of operations was
huggingface-cli login
(Copy token to clipboard)
right click to paste (trust that it pastes, it won’t show)
(hit ENTER)


This worked. Thank you.

yeah!! Thank you very much I was struggling at that point and now my toker is valid, have a good one

You can open python in the prompt and use huggingface_hub.login

1 Like

python prompt is a winner…don’t forget the import

import huggingface_hub

I did in VSCODE. the problem is that the prompt does NOT SHOW the token. What i did (WINDOWS):

  1. copy and paste your token
  2. run the cli huggingface-cli login
  3. click in the blinking cursor and then select the token written before and right-click twice
(enviroment\.conda) C:\My\project\path\> token123
>>> 'token123' is not recognized as an internal or external command,
operable program or batch file.
(enviroment\.conda) C:\My\project\path\> huggingface-cli login
    _|    _|  _|    _|    _|_|_|    _|_|_|  _|_|_|  _|      _|    _|_|_|      _|_|_|_|    _|_|      _|_|_|  _|_|_|_|
    _|    _|  _|    _|  _|        _|          _|    _|_|    _|  _|            _|        _|    _|  _|        _|
    _|_|_|_|  _|    _|  _|  _|_|  _|  _|_|    _|    _|  _|  _|  _|  _|_|      _|_|_|    _|_|_|_|  _|        _|_|_|
    _|    _|  _|    _|  _|    _|  _|    _|    _|    _|    _|_|  _|    _|      _|        _|    _|  _|        _|
    _|    _|    _|_|      _|_|_|    _|_|_|  _|_|_|  _|      _|    _|_|_|      _|        _|    _|    _|_|_|  _|_|_|_|

    To login, `huggingface_hub` requires a token generated from .
Token can be pasted using 'Right-Click'.
Token: | (blinking cursor)
  1. press ENTER and follow the instructions :grin:
1 Like

I had the same problem and succeeded with this command:

huggingface-cli login --token [your token]

I got this solution from the help command:

huggingface-cli login --help
usage: huggingface-cli [] login [-h] [–token TOKEN] [–add-to-git-credential]


I’m in the same boat and none of the solutions above works.

YES. It worked


thanks tons man