Whisper on SageMaker - how to stop it from translating the result?

Hey there,

by using SageMaker DLC (and also upgrading transformers library from 4.17 to 4.26 with custom requirements.txt), I am able to send speech and get the text back.

However, if the language is non-english, the output will get automatically translated to English. Is there an easy way to change this behaviour?

Additional question, can I somehow also send inference parameters for Whisper along with the audio (like setting the temperature) (this is the same question as the one posted here)? I’m using DataSerializer(content_type='audio/x-audio').