Build Error: No such file or directory: ''

Tried deploying a new space (link). Getting a FileNotFoundError for

  × python egg_info did not run successfully.
  │ exit code: 1
  ╰─> [8 lines of output]
      Traceback (most recent call last):
        File "<string>", line 2, in <module>
        File "<pip-setuptools-caller>", line 34, in <module>
        File "/tmp/pip-install-kmt8ulnm/uvicorn_aa5a2ea15bd9448fad5c8bad63a1af3d/", line 41, in <module>
        File "/tmp/pip-install-kmt8ulnm/uvicorn_aa5a2ea15bd9448fad5c8bad63a1af3d/", line 23, in get_long_description
          return open('', 'r').read()
      FileNotFoundError: [Errno 2] No such file or directory: ''
      [end of output]
1 Like

Please update the requirements.txt to use the latest Gradio version

gradio== 3.44.1

That worked, thank you!

1 Like

Doesn’t seem to work for me: KawaiiApp/anythingv3 at main

hi @KawaiiApp
It looks like a Gradio issue, please use the latest version gradio==3.44.3

Hi @radames! That didn’t seem to work. Anything else I could do? Thanks so much for the response. I appreciate

Check your readme file and make sure Gradio sdk version (if listed) is updated.

adding gradio==3.44.3 or gradio==3.44.1 in requirement.txt doesn’t work. I looked at the build logs

--> RUN pyenv install 3.10 && 	pyenv global 3.10 && 	pyenv rehash && 	pip install --no-cache-dir --upgrade pip==22.3.1 setuptools wheel && 	pip install --no-cache-dir 	datasets 	"huggingface-hub>=0.12.1" "protobuf<4" "click<8.1" "pydantic~=1.0" "uvicorn>=0.14.0"
Collecting uvicorn>=0.14.0
  Downloading uvicorn-0.23.2-py3-none-any.whl (59 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 59.5/59.5 kB 329.1 MB/s eta 0:00:00
--> RUN --mount=target=requirements.txt,source=requirements.txt 	pip install --no-cache-dir -r requirements.txt

--> RUN pip install --no-cache-dir 	gradio[oauth]==3.6 	spaces==0.16.0
INFO: pip is looking at multiple versions of uvicorn to determine which version is compatible with other requirements. This could take a while.
Collecting uvicorn

The error occurs in the last RUN command while installing gradio[oauth]==3.6 spaces==0.16.0

Hi @Styldod ! Make sure the version in the README matches the version in requirements.txt. That way it won’t get overridden