Max-length for gpt-j and other questions

I am subscribed to huggingface at the $9.00 per month level. I want to use the gpt-j model from Eleuther. When I try the code in the curl example I get some output, but not very much. When I use my code I get a single word as output. My code uses a prompt that is much longer.

I believe this to be an issue with the max-length option for the model. My first question is, how do I set the max-length to be something longer so that I can use huggingface’s gpt-j with my longer prompt. I cannot find anywhere in the documentation how to set the max-length using curl, or in my case, from a javascript application. I believe there to be instructions on setting the max-length in the python example, but not for curl.

My second question is whether I need to pay more to get these features. I don’t know about this. I might be willing if I knew that the model would perform well (quickly, etc.)

Thank you for your time.