No custom pipeline found at /repository/

I have a stable diffusion 1.5 model hosted on huggingFace. I am trying to spin up an interface endpoint for it, to provide my community with faster response times and better uptime.

But I keep running into the following error:

Initializing model from directory:/repository
b997n 2023-03-31T22:35:49.795Z 2023-03-31 22:35:49,795 | INFO | No custom pipeline found at /repository/

I tried running the CPU endpoint Small and Medium.

Honestly paying more than 80 dollars a month for my use as I am still learning is too much.

How can I fix this issue?

Are there better services than interface endpoints for my goal?

Could you please share you repository? Are you trying to customize inference. through a
Also CPUs are not a good for Stable diffusion models neither in size nor performance.

I have found a solution in the huggingFace docs, found a custom for stable diffusion models, but when I tried running it, the build has always failed.

Is it possible the small and medium CPUs aren’t enough?

Paying 400 dollars a month just to test out an interface endpoint seems like too much to me, combined with the fact I pay per hour, not per compute.

Yes, the pipeline overall is > 7-8GB and even if you manage to run on CPU the generation will take minutes.

For testing you can use the inference-api which is free through the inference widgets or programmatically.