ValueError (unknown key enable_cpu_affinity) on SageMaker for Accelerate >=0.29.0

Hi all,

I encountered the following error on accelerate version 0.30.0

ValueError: The config file at ./accelerate_config.yaml had unknown keys (['enable_cpu_affinity']), please try upgrading your `accelerate` version or fix (and potentially remove) these keys from your config file. 

The weird part, I did not have this key in my config file at all!

I traced back the error to this line, which adds the enable_cpu_affinity key. Looks like this key was not added in the SageMakerConfig class here (though it was added for the ClusterConfig class on line 185. This is causing us to hit the Value Error condition on line 152.

For now, I am using accelerate 0.28.0 to work around this issue, as this change was introduced to accelerate on May 20. Hoping the HF team can resolve this for the latest version!

I have the same error on accelerate 0.28.0.
How did you worked around this issue?

Please update your accelerate version, we released a patch which fixed it!

1 Like

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.