Workflow: how to avoid dummy_pt_objects.py in IDE search results?

I always click the first result, which is often a dummy. Has anyone found a pycharm workaround?
Some way to specify paths that search should ignore?

Great question, Sam!

right click on dummy_objects.py and click “mark as plain text”

h/t phpstorm docs (works in pycharm).

4 Likes

When working in pycharm with transformers as an External Library, I couldn’t get this to work (i.e. when I want to read the source code for a specific method from an external library managed by pip or conda).

But the following fixed it:
(pycharm) preferences > file types > ignore files and folders > add “;dummy_*.py;”

2 Likes

Has anyone gotten this working in vscode? Maybe @julien-c ?

I haven’t hit this issue but maybe just b/c my workflow does not lead me into it. Not sure 🤷

Lol, I would love for VSCode to start trying to show me the origin of classes/functions.

Cmd+Click or Find all references work reasonably well for me, isn’t that the case for you?

I’ve mostly tried Go To Definition, which works erratically so stopped digging too much. Will try again when I’m at my machine with Find all references (in the remote extension, any of those commands takes a long time for no result).

Also if I remember correctly there are two distinct backends for the python extension in vscode. One is experimental and doesn’t work well, while the mature one is working ok (but has native dependencies or is more ancient).

1 Like

For me, the setting is:
Settings > Editor > File Types > Ignore Files and Folders > File name patterns [click ‘+’] > dummy_*.py