Authorization Error with Factory Rebuild of my HF Space


The Space was having some missing openai library error (though none did any changes in 2 months and the space was working perfectly fine last week) so I decided to perform a “Factory rebuild”. However I encountered this error:

--> ERROR: failed to push failed to authorize: failed to fetch anonymous token: unexpected status from GET request to 401 Unauthorized

Full logs here: Leaderboard Gradio - a Hugging Face Space by valory

Could someone bring some help here please? I have my write token valid for this space so no idea which extra token is asking for…


does this have sth to do with the internal certificates at Hugging Face? @radames @michellehbn

Ok the thing now is that I have a submodule giving problems connected with a specific commit

Submodule path 'olas-predict-benchmark/benchmark/mech': checked out '10fbda742b97470b0916204c0c80f40f8acfb1e5'

I updated the repo to point now to a different commit

➜  olas-predict-benchmark git:(main) git submodule status                                                                   
 f09951f1df6fd39b4f1a7298d17bfb84b3e6cff2 benchmark/mech (v0.7.0-310-gf09951f)

I pushed the update of the configuration to the hugging face repository but the hugging face space is always going to the old configuration.
Tried to restart the space, to push new commits to force a build and to do a factory rebuild. The build is not getting my changes.

Please help.
Many thanks.

have you tried without docker?

Hi Nikita,

Thanks for your answer.
Now I have a different error to solve with libraries dependencies conflict but… I would like to know how could I start the app on the HF Space without docker. I guess at the HF Space server creating a docker container is the only option… :thinking: