Building stuck on «Scheduling space» [since last Sunday]


I’ve been using Hugging Face for a few weeks.

Until last Sunday, I could build my space without problems.

Starting on Sunday, the build process get stuck on the «Scheduling space» until there’s a runtime error.

I’ve been wasting a lot of time (and some money) on trying to get the space to build again. Couldn’t find the way.

I’ve been unable to do any work. I’m close to giving up.

I’m paying for the GPU and I’m paying the PRO subscription: tbh, it’s frustrating there’s no straightforward way to ask for support.


hi @EnricoPoli , sorry for the inconvenience. During the weekend we had crypto miners abusing our infra

Can you please try a factory reboot? and maybe share more details of the runtime error? feel free to DM

Thanks, Radames.

I tried the factory reboot many many times, day after day, just to see if it would fix itself with time. It doesn’t.

The runtime error was about not being able to access the logs.

I tried to reproduce it, but this time the space has been stuck on «scheduling space» for hours without erroring, so I finally moved it back to the free CPU. In the meantime, it charged me $8 for doing nothing and waiting for «scheduling space». I feel cheated, and frankly I’m not going to renew the pro subscription next month.

Hi @EnricoPoli, we found the source of the issue, and we’re addressing it to provide a better DX. Essentially the Docker image generated on your Space was too big. Thus after the build, your container was evicted due to storage limitations.
I’ll DM you for more details. Thanks, and sorry for the inconvenience.