Discussion about the model API

Thread to collect all feedback regarding the public API of the code in src/diffusers/models

Note: At the moment we only care about the following files:

  • code in the file src/diffusers/models/unet_conditional.py (UNetConditionalModel)
  • code in the file src/diffusers/models/unet_unconditional.py (UNetUnconditionalModel)
  • code in the file src/diffusers/models/unet_blocks.py

Please only give feedback about the following files as the other files are not finished yet.

To better understand what exactly a model is, please see: GitHub - huggingface/diffusers

I think we should rename UNetUnconditionalModel to just UNetModel2D and UNetConditionalModel to UNetConditionModel2D (like Nathan suggested)

Also num_res_blocks should probably be replaced by num_res_layers as it defines the number of residual layers per block