Issue installing Transformers from source

Hi!

I’ve run into an issue whilst trying to update from Transformers 4.18.0 to Transformers 4.23.0.
I followed suggested approach at Installation both with and without a virtual environment, yet I keep getting the following error:

ERROR: Could not find a version that satisfies the requirement huggingface-hub<1.0,>=0.9.0 (from transformers) (from versions: 0.0.1, 0.0.2, 0.0.3rc1, 0.0.3rc2, 0.0.5, 0.0.6, 0.0.7, 0.0.8, 0.0.9, 0.0.10, 0.0.11, 0.0.12, 0.0.13, 0.0.14, 0.0.15, 0.0.16, 0.0.17, 0.0.18, 0.0.19, 0.1.0, 0.1.1, 0.1.2, 0.2.0, 0.2.1, 0.4.0)
ERROR: No matching distribution found for huggingface-hub<1.0,>=0.9.0

Has anyone encountered a similar issue by any chance or have suggestions as to how to solve it?
Any help would be much appreciated