Query regarding Generating Network Commands using "Intention" of users , using Large Language Models

Hello, thank you for taking time to read this question.

For my Final-Project, I am trying to generate Network Commands based on some input provided by the user. This input is what I am calling “intent”, which is nothing but a simple description of what users want to achieve, written in a Simple English Statement.

Description of the Network Commands: These Network Commands are generated for Cisco Packet Tracer. First of all, what I have done is drawn a topology, which is inherently fixed, and I am trying to automate the process of generating the network commands, instead of writing those commands, if somehow they could be generated by LLM or any sort of AI Model trained on a similar Dataset. Now there are assumptions made, such as the Network commands generated for the assignment of IP addresses, subnets, Routing, and enable Password, etc., would be fixed (static routing and /30 subnet) and would be limited upon the capability of Cisco Packet Tracer. I have just three use-cases (generating network commands for PPP (point-to-point), IPSEC (VPN configuration), and ACL (Access-Control-Lists)).

Description of Intents: These are just basic commands in English, which describe the intention of the user, so for all three use-cases, in each use-case the User would have different intents, based on the topology and his intention (We are assuming that the user has the relevant background knowledge about how a network works and he can, therefore, input relevant intents in the network).

Some examples are the following:

Use-case (PPP):

Intent (variation 1): Set up Basic Router Configuration

Network commands: 
R1:no
enable
configure terminal
hostname R1
enable secret cisco1
line console 0
password cisco2
login
exit
exit
exit
R2:no
enable
configure terminal
hostname R2:
enable secret cisco1
line console 0
password cisco2
login
exit
exit
exit
R3:no
enable
configure terminal
hostname R3
enable secret cisco1
line console 0
password cisco2
login
exit
exit
exit

Intent (variation 2): Perform IP configuration on the network

Network commands: 
R1:enable
cisco1
configure terminal
interface serial 2/0
ip address 10.1.1.1 255.255.255.0
no shutdown
exit
exit
exit
R2:enable
cisco1
configure terminal
interface serial 2/0
ip address 10.1.1.2 255.255.255.0
no shutdown
exit
interface serial 3/0
ip address 10.2.2.1 255.255.255.0
no shutdown
exit
exit
exit
R3:enable
cisco1
configure terminal
interface serial 3/0
ip address 10.2.2.2 255.255.255.0
no shutdown
exit
exit
exit

Use-case (IPSEC):

Intent (variation 1): Establish a secure VPN link between R1 and R3 with minimal security measures.

Network commands: 
R1:cisco1
enable
cisco2
configure Terminal
crypto isakmp policy 30
hash md5
authentication pre-share
group 1
lifetime 86400
encryption des
exit
crypto isakmp key cisco123 address 10.2.2.2
crypto ipsec transform-set R1-R3-SET esp-des esp-md5-hmac
access-list 110 permit ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
crypto map R1-R3-MAP 10 ipsec-isakmp
description VPN Connection between R1 and R3
set peer 10.2.2.2
set transform-set R1-R3-SET
match address 110
exit
interface gigabitEthernet 0/0/0
crypto map  R1-R3-MAP
R3: cisco1
enable
configure Terminal
crypto isakmp policy 30
hash md5
authentication pre-share
group 1
lifetime 86400
encryption des
exit
crypto isakmp key cisco123 address 10.1.1.1
crypto ipsec transform-set R1-R3-SET esp-des esp-md5-hmac
access-list 110 permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
crypto map R1-R3-MAP 10 ipsec-isakmp
description VPN Connection between R1 and R3
set peer 10.1.1.1
set transform-set R1-R3-SET
match address 110
exit
interface gigabitEthernet 0/0/0
crypto map R1-R3-MAP  

Use-case (ACL):

Intent: Block the Access of Employee of Branch 2 to the Manager of Branch 1

Network commands: 
cisco1
enable
configure terminal
access-list 101 deny ip host 192.168.20.3 host 192.168.10.2
access-list 101 permit ip any any
interface FastEthernet 0/0
ip access-group 101 in
exit
exit

.P.S: I have added the newline character after every command, making it one big line odf commands separated by newlines, in the training data
MY QUESTION:

Which model (Preferably Open-sourced) do I use and how do I train it, currently experimentation is going on with GPT-2 but all in vain, just getting about 2 lines of the network commands and then the model keeps repeating them. I need help with it urgently as this helps my capstone.

Training Dataset Details:

  • PPP: 700 lines, CSV, two columns (Intent + Network Commands)
  • ACL: 3600 lines, CSV, two columns (Intent + Network Commands)
  • IPSEC: 1600 lines, CSV, two columns (Intent + Network Commands)

Our group is trying GPT-2, Google T5 model, but it is giving a really small number of outputs (just some lines of the network commands and then just repeating them consecutively for some network intents).