Quickstart Dataset

Greetings! I’m in the quickstart tutorial on an Macbook running M1. I’ve already installed the Datasets from terminal, but when I run:

pip3 install datasets[audio]

I receive back: ‘zsh: no matches found: datasets[audio]’

I have already confirmed that I successfully installed datasets using:

python3 -c "from datasets import load_dataset; print(load_dataset('squad', split='train')[0])"

Any help would be appreciated. Thanks!

1 Like

SOLVED: I installed this dependency

pip3 install soundfile

This code works now:

from datasets import load_dataset
mindsFR = load_dataset("PolyAI/minds14", "en-US", split="train")

I’m glad you made it work :slight_smile:

For future reference, I think in some terminals you need to escape the brackets:

pip3 install datasets\[audio\]
1 Like

thank you. Can confirm that this works for anaconda / jupyter

this work for me, i run !pip install datasets[audio] and encounter the same err as above.

!pip install datasets\[audio\]

resolve the problem