Run with Docker Locally? -

Which credentials are we supposed to use here? docker login

My Docker hub credentials don’t work, the Huggingface login credentials don’t work, I literally do not know what to do.


Hey there! Sorry for the issue, we need to clarify better. Your credentials should be:

Username: hugging face username
Password: An access token from your settings page


@osanseviero omg, thank you, this isn’t documented ANYWHERE as far as I can tell.

Now to figure out why none of the spaces I’ve tried allow it to work…

6ae770d6091b: Download complete
5ec58819c216: Download complete
1abaf77c7bc2: Download complete
86043062ced9: Download complete
65f692d82037: Download complete
8c5ed5b26834: Download complete
4d09f00857ba: Download complete
3dd0caf39ec0: Download complete
795768a1f135: Download complete
8edeac37e1d7: Download complete
91ce43dd5db1: Download complete
docker: failed to register layer: Error processing tar file(exit status 1): archive/tar: invalid tar header.
See ‘docker run --help’.

1 Like

Yes, you need to set containerd as mentioned in the page

You need to switch on the new containerd engine in Docker for pulling and storing images. This will be the new Docker default in the future. Read more

If that does not work, I would also suggest to use the latest Docker Desktop version as we use some features that are in beta.

I’m facing the same issue as @iamrobotbear

fb668870d8a7: Pull complete 
8a612414e2bc: Pull complete 
2c12f5dee74d: Pull complete 
e8b64516db7f: Pull complete 
5063cc75a5fc: Pull complete 
0b5eea1e39eb: Pull complete 
19026083d6ce: Pull complete 
9ec6d9577f70: Pull complete 
4d04e22a64a3: Pull complete 
c89166c8ea49: Pull complete 
76b0ea444c14: Pull complete 
bc5a04c3e525: Pull complete 
0f63c1049832: Extracting  263.3MB/263.3MB
942948180013: Download complete 
f192ca193561: Download complete 
689017106e43: Download complete 
9b47ef56fce2: Download complete 
4f941b704304: Download complete 
46995db4b389: Download complete 
0566a60652fd: Download complete 
a627c5514c75: Download complete 
2663a1b669bf: Download complete 
docker: failed to register layer: Error processing tar file(exit status 1): archive/tar: invalid tar header.

A few other users mentioned the same error on Linux / OS X in this Twitter thread:


I was having a similar problem with running the image besides other images.

The error was always the same: “Error processing tar file(exit status 1): archive/tar: invalid tar header” in the last stage of the download.

FYI it was not a login issue, I had already logged in to my huggingface account and I am running this on a virtual instance, in Debian 10 setting.

I could solve this error by correctly installing dockers on the instance, following the guidelines given in Install Docker Engine on Debian | Docker Documentation .

still have the issue, link Failed to pull images from

I solved this error by reinstalling docker with the latest version on ubuntu 20.04.

1 Like