Tokenizer issue in Huggingface Inference on uploaded models

While inferencing on the uploaded model in huggingface, I am getting the below error,

Can’t load tokenizer using from_pretrained, please update its configuration: Can’t load tokenizer for ‘bala1802/model_1_test’. Make sure that: - ‘bala1802/model_1_test’ is a correct model identifier listed on ‘Hugging Face – On a mission to solve NLP, one commit at a time.’ - or ‘bala1802/model_1_test’ is the correct path to a directory containing relevant tokenizer files

How to configure the tokenizer in config file ?

The configuration file looks like below,

“_name_or_path”: “gpt2”,
“activation_function”: “gelu_new”,
“architectures”: [
“attn_pdrop”: 0.1,
“bos_token_id”: 50256,
“embd_pdrop”: 0.1,
“eos_token_id”: 50256,
“gradient_checkpointing”: false,
“initializer_range”: 0.02,
“layer_norm_epsilon”: 1e-05,
“model_type”: “gpt2”,
“n_ctx”: 1024,
“n_embd”: 768,
“n_head”: 12,
“n_inner”: null,
“n_layer”: 12,
“n_positions”: 1024,
“resid_pdrop”: 0.1,
“summary_activation”: null,
“summary_first_dropout”: 0.1,
“summary_proj_to_labels”: true,
“summary_type”: “cls_index”,
“summary_use_proj”: true,
“task_specific_params”: {
“text-generation”: {
“do_sample”: true,
“max_length”: 50
“transformers_version”: “4.3.2”,
“use_cache”: true,
“vocab_size”: 50257

Hi @bala1802, I just tried your text generation model on the inference API (link) and it seems to work without any error - perhaps you found a way to solve your problem?


Yes I uploaded the missing tokenizer files. Now it’s working.

Thanks for getting back

1 Like

Hi I am facing the same error, I only have the config.json and tf_model.h5 files, is there any I need to upload?

I have also tried push_to_hub() and I am getting the below error:

Already pip installed git-lfs via jupyter lab and logged in to notebook