Transformers installation issue with conda

conda by default installing transformers 2.x however pip installs 4.x by default which is what I want but via conda.

If I install by specifying the latest distribution file from conda-forge…
conda install

then it complains that environment is not consistent and list the package causing the issue which is PyTorch version 1.11.

I removed pytorch and then installed as listed above then installation go through. I then tried installing datasets…
conda install datasets

Now it complains that environment is inconsistent due to transformers 4.16.2 that I installed.

Not sure whats wrong and how to install pytorch, transformers and datasets together with no issue.
Do I need specific versions of these to make it work, could not find any such guideline on huggingface docs or support pages.


This looks like python version dependency issue. Tried in a new blank environment and first package I tried to install was transformers … conda install -c huggingface transformers . This time it picked up transformers version 4.x and python version 3.8x . Now, if I first install python 3.9.x (which is default with miniconda) and then try to install transformer then it falls back to version 2.x. This tell me that in order to have version 4.x I need python version 3.8 or lower. This is not listed anywhere in huggingface installation page though.