Xnli is not loading

I’m trying to load the xnli dataset like this:
xnli = nlp.load_dataset(path=‘xnli’)

and i got an error:
ConnectionError: Couldn’t reach https://www.nyu.edu/projects/bowman/xnli/XNLI-1.0.zip

Can someone tell me what’s the problem and can i get this dataset some other way?
Thanks in advance

Hi,

the nlp project was renamed to datasets over a year ago, so I’d suggest you install that package and let us know if you still have issues downloading the dataset.

Hi, thanks for replying.
I installed datasets and tried loading xnli dataset:

xnli = load_dataset(path=‘xnli’)

but I get another error:
FileNotFoundError: No data files or dataset script found in xnli

so it still doesn’t work. :(. Whar’s the problem?

It works on my side. Are you sure you haven’t created a directory with the name xnli (relative to your script) that is now interfering? What does print(os.path.exists("xnli")) return when you run it in your script?

1 Like

I’m sure I created such directory. That was the problem. It works fine now. Thank you very much! :smiley: