Your request to access this repo has been successfully submitted, and is pending a review from the repo's authors

Hi,

I have a Pro account of Hugging Face. But when I try to call the HuggingFace Model API, I get this error :-
OSError: You are trying to access a gated repo.
Make sure to request access at meta-llama/Llama-2-70b-chat-hf · Hugging Face and pass a token having permission to this repo either by logging in with huggingface-cli login or by passing token=<your_token>

When I logged in to my Hugging face Account, I got this message :- Your request to access this repo has been successfully submitted, and is pending a review from the repo’s authors.

Can anyone please help me over this issue for why have I not been granted access to this repository after having a Pro Account.

I’m stuck due to this in one of my critical projects.
And it is an urgent requirement to get this issue resolved as soon as possible.

Quick leads are highly appreciated.
Thanks in Advance.

Same problem here. I’m probably waiting for more than 2 weeks. Any information on how to resolve this is greatly appreciated.

I am having the same problem. Although I have the access from Meta’s side. Anybody been able to resolve this please?

1 Like

When it means login to login, it means to login in code, not go on the website.

As in:

from huggingface_hub import login

login("hf_XXXXXXXXXXX")

Also make sure that in addition to requesting access on the repo on HuggingFace, make sure you also went to Meta’s page and agreed to the terms there in order to get access below (this text is on the HuggingFace repo as well):


So when Meta approves your request and allows you access to the repo, login using the code and then you can import it successfully. Hope this helps.

6 Likes

Thanks for this one

Same here waiting for more than 2 weeks. Any solutions?

thank you for this

I did use the login code.
Even though the token has been input, the error still occurs - ‘Cannot access gated repo for url https://huggingface.co/meta-llama/Llama-2-7b-chat-hf/resolve/main/config.json. Your request to access model meta-llama/Llama-2-7b-chat-hf is awaiting a review from the repo authors.’

Anyone has the same issue?

Getting the similar issues. Used “!huggingface-cli login” to login into huggingface using the token. After executing HuggingFaceLLM({Passed_all_parameters}}) getting the “Cannot access gated repo for url https://huggingface.co/meta-llama/Llama-2-7b-chat-hf/resolve/main/config.json.
Access to model meta-llama/Llama-2-7b-chat-hf is restricted and you are not in the authorized list.”
Can anyone please help.

thanks , that worked, but didnt understood why this “!huggingface-cli login” is failing in vs code, but worked in colab

metallama需要审核,需要更换可免费使用的模型,比如:

  • GPT-2
  • GPT-3
  • GPT-NeoX
  • BLOOM