Bug-Free Gradio Interface not loading on HFS

My faulty space:

and its duplicate, also faulty:

This is not an ML deployment and the problem is, I assume, only an interface problem and not do with my python code.

I’m using the Gradio Blocks feature which is listed as ‘new’ in the documentation.
My interface was working, until I made a change and then it wasn’t. It builds and says running. The logs say it is running and hosted etc. But the ‘App’ page is just the little 2 yellow squares gradio animation, but frozen. The app isnt there to be interacted with.

I tried all of the following, no joy:

  • Commenting out the most recent lines of code in the interface after which the bug presented itself
    *Commenting out significantly larger chunks of the code until the interface was almost nothing. Still not loading
  • Restarting computer
  • Different browser
  • Opening on mobile
  • Creating a new space and copying all same files etc into it. Same problem

I tried running jupyter on my computer, and then running my app file locally. This worked. While, in jupyter, there is still the same image of the yellow blocks frozen, im not sure if its supposed to be animated. I click the local hosted link and it opens in a new tab, working.

Any way I can get HFS working for my app again? I was just about ready to deploy to end users… Considering there are no error reports whatsoever I cant make sense of this.