Bug: Share my uploaded models publicly by default

hello! I signed up and saw this checkbox on the /join page:

I installed the CLI, logged in, and uploaded a model. I was surprised to see that it was listed publicly in the search index, and that there was no way to change this. See https://huggingface.co/kevinrobinson/perturbations_table_quickstart for an example.

Am I misunderstanding that checkbox? If so, it’d be great to understand how to upload models and have them not be listed in the public search index, or if this isn’t supported then it could help to clarify what this option is on the /join page. Thanks!