Cannot install datasets library in conda

I was installing datasets using conda install -c huggingface -c conda-forge datasets but failed. What is the problem?

Channels:
 - huggingface
 - conda-forge
 - defaults
 - anaconda
 - intel
Platform: osx-64
Collecting package metadata (repodata.json): done
Solving environment: - warning  libmamba Added empty dependency for problem type SOLVER_RULE_UPDATE
failed

LibMambaUnsatisfiableError: Encountered problems while solving:
  - nothing provides _python_rc needed by python-3.12.0rc3-rc3_h30d4d87_1_cpython

Could not solve for environment specs
The following packages are incompatible
β”œβ”€ anyio 4.0.0.*  is requested and can be installed;
β”œβ”€ brotli-python 1.1.0.*  is installable with the potential options
β”‚  β”œβ”€ brotli-python 1.1.0 would require
β”‚  β”‚  └─ libbrotlicommon 1.1.0 h0dc2134_0, which can be installed;
β”‚  β”œβ”€ brotli-python 1.1.0 would require
β”‚  β”‚  └─ libbrotlicommon 1.1.0 h0dc2134_1, which can be installed;
β”‚  β”œβ”€ brotli-python 1.1.0 would require
β”‚  β”‚  └─ python >=3.10,<3.11.0a0 , which can be installed;
β”‚  β”œβ”€ brotli-python 1.1.0 would require
β”‚  β”‚  └─ python >=3.12.0rc3,<3.13.0a0  with the potential options
β”‚  β”‚     β”œβ”€ python [3.12.0|3.12.1], which can be installed;
β”‚  β”‚     └─ python 3.12.0rc3 would require
β”‚  β”‚        └─ _python_rc, which does not exist (perhaps a missing channel);
β”‚  β”œβ”€ brotli-python 1.1.0 would require
β”‚  β”‚  └─ python >=3.8,<3.9.0a0 , which can be installed;
β”‚  └─ brotli-python 1.1.0 would require
β”‚     └─ python >=3.9,<3.10.0a0 , which can be installed;
β”œβ”€ datasets is installable with the potential options
β”‚  β”œβ”€ datasets [1.1.3|1.10.0|...|2.9.0], which can be installed;
β”‚  β”œβ”€ datasets [2.15.0|2.16.0|2.16.1] would require
β”‚  β”‚  └─ pyarrow >=8.0.0  with the potential options
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0|...|9.0.0] would require
β”‚  β”‚     β”‚  └─ python >=3.10,<3.11.0a0 , which can be installed;
β”‚  β”‚     β”œβ”€ pyarrow [8.0.0|8.0.1|9.0.0] would require
β”‚  β”‚     β”‚  └─ python >=3.7,<3.8.0a0  with the potential options
β”‚  β”‚     β”‚     β”œβ”€ python [3.7.0|3.7.1|...|3.7.9], which can be installed;
β”‚  β”‚     β”‚     └─ python [3.6.7|3.7.1] would require
β”‚  β”‚     β”‚        └─ openssl >=1.1.1,<1.1.2.0a0 , which does not exist (perhaps a missing channel);
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0|...|9.0.0] would require
β”‚  β”‚     β”‚  └─ python >=3.8,<3.9.0a0 , which can be installed;
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0|...|9.0.0] would require
β”‚  β”‚     β”‚  └─ python >=3.9,<3.10.0a0 , which can be installed;
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0|...|9.0.0] would require
β”‚  β”‚     β”‚  β”œβ”€ arrow-cpp [8.0.1 py311h02a6a7a_22_cpu|8.0.1 py311h15d7f3f_6_cpu|...|9.0.0 py311hfb3f5be_9_cpu], which requires
β”‚  β”‚     β”‚  β”‚  β”œβ”€ libarrow [10.0.1 h0b3ac1b_33_cpu|10.0.1 h0b3ac1b_34_cpu|...|11.0.0 hf6017ac_3_cpu], which requires
β”‚  β”‚     β”‚  β”‚  β”‚  β”œβ”€ libbrotlicommon >=1.0.9,<1.1.0a0 , which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  β”‚  └─ libbrotlienc >=1.0.9,<1.1.0a0  but there are no viable options
β”‚  β”‚     β”‚  β”‚  β”‚     β”œβ”€ libbrotlienc 1.0.9 would require
β”‚  β”‚     β”‚  β”‚  β”‚     β”‚  └─ libbrotlicommon 1.0.9 h0d85af4_5, which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  β”‚     β”œβ”€ libbrotlienc 1.0.9 would require
β”‚  β”‚     β”‚  β”‚  β”‚     β”‚  └─ libbrotlicommon 1.0.9 h0d85af4_6, which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  β”‚     β”œβ”€ libbrotlienc 1.0.9 would require
β”‚  β”‚     β”‚  β”‚  β”‚     β”‚  └─ libbrotlicommon 1.0.9 h5eb16cf_7, which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  β”‚     β”œβ”€ libbrotlienc 1.0.9 would require
β”‚  β”‚     β”‚  β”‚  β”‚     β”‚  └─ libbrotlicommon 1.0.9 hb7f2c08_8, which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  β”‚     β”œβ”€ libbrotlienc 1.0.9 would require
β”‚  β”‚     β”‚  β”‚  β”‚     β”‚  └─ libbrotlicommon 1.0.9 hb7f2c08_9, which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  β”‚     └─ libbrotlienc 1.0.9 would require
β”‚  β”‚     β”‚  β”‚  β”‚        └─ libbrotlicommon 1.0.9 hca72f7f_7, which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  β”œβ”€ libbrotlicommon >=1.0.9,<1.1.0a0 , which conflicts with any installable versions previously reported;
β”‚  β”‚     β”‚  β”‚  └─ libbrotlienc >=1.0.9,<1.1.0a0 , which cannot be installed (as previously explained);
β”‚  β”‚     β”‚  └─ libarrow [10.0.1 *_33_cpu|10.0.1 *_34_cpu|...|13.0.0 ha268fe5_0_cpu], which cannot be installed (as previously explained);
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0|12.0.1|13.0.0] would require
β”‚  β”‚     β”‚  └─ libarrow [10.0.1 hce17ce0_42_cpu|11.0.0 heeec12f_38_cpu|12.0.1 heeec12f_13_cpu|13.0.0 heeec12f_4_cpu], which requires
β”‚  β”‚     β”‚     └─ libabseil >=20230802.0,<20230803.0a0 , which can be installed;
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0|...|9.0.0] would require
β”‚  β”‚     β”‚  β”œβ”€ arrow-cpp 9.0.0 py311h0ea927f_50_cpu, which requires
β”‚  β”‚     β”‚  β”‚  β”œβ”€ libabseil >=20230802.1,<20230803.0a0 , which can be installed;
β”‚  β”‚     β”‚  β”‚  └─ libarrow [10.0.1 h161d478_54_cpu|10.0.1 h17c06f9_45_cpu|...|11.0.0 heeec12f_40_cpu], which requires
β”‚  β”‚     β”‚  β”‚     └─ libabseil >=20230802.1,<20230803.0a0 , which can be installed;
β”‚  β”‚     β”‚  β”œβ”€ libarrow [10.0.1 h161d478_54_cpu|10.0.1 h17c06f9_45_cpu|...|13.0.0 hf510195_15_cpu], which can be installed (as previously explained);
β”‚  β”‚     β”‚  └─ libarrow-flight [14.0.0 h440f1c2_0_cpu|14.0.1 h440f1c2_2_cpu|...|14.0.2 ha1803ca_2_cpu], which requires
β”‚  β”‚     β”‚     └─ libabseil >=20230802.1,<20230803.0a0 , which can be installed;
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0|12.0.1|13.0.0|9.0.0] would require
β”‚  β”‚     β”‚  β”œβ”€ arrow-cpp [9.0.0 py311h2e40684_49_cpu|9.0.0 py311h310d3e5_48_cpu|9.0.0 py311hd93bb85_47_cpu], which requires
β”‚  β”‚     β”‚  β”‚  β”œβ”€ libarrow [10.0.1 h6b1e468_41_cpu|10.0.1 h8171123_40_cpu|...|11.0.0 hdcd9b72_35_cpu], which requires
β”‚  β”‚     β”‚  β”‚  β”‚  └─ libgrpc >=1.56.2,<1.57.0a0 , which can be installed;
β”‚  β”‚     β”‚  β”‚  └─ libgrpc >=1.56.2,<1.57.0a0 , which can be installed;
β”‚  β”‚     β”‚  └─ libarrow [10.0.1 h6b1e468_41_cpu|10.0.1 h8171123_40_cpu|...|13.0.0 hdcd9b72_1_cpu], which can be installed (as previously explained);
β”‚  β”‚     β”œβ”€ pyarrow [11.0.0|13.0.0|14.0.0|14.0.1|14.0.2] would require
β”‚  β”‚     β”‚  └─ python >=3.12,<3.13.0a0 , which can be installed;
β”‚  β”‚     β”œβ”€ pyarrow [10.0.1|11.0.0] would require
β”‚  β”‚     β”‚  └─ arrow-cpp [>=10.0.1,<10.0.2.0a0 |>=11.0.0,<11.0.1.0a0 ] with the potential options
β”‚  β”‚     β”‚     β”œβ”€ arrow-cpp [10.0.1|11.0.0|8.0.0|8.0.1|9.0.0], which cannot be installed (as previously explained);
β”‚  β”‚     β”‚     β”œβ”€ arrow-cpp [10.0.1|11.0.0|9.0.0], which can be installed (as previously explained);
β”‚  β”‚     β”‚     β”œβ”€ arrow-cpp [10.0.1|11.0.0] would require
β”‚  β”‚     β”‚     β”‚  └─ libarrow [10.0.1 hce17ce0_42_cpu|11.0.0 heeec12f_38_cpu], which can be installed (as previously explained);
β”‚  β”‚     β”‚     β”œβ”€ arrow-cpp [10.0.1|11.0.0|9.0.0], which can be installed (as previously explained);
β”‚  β”‚     β”‚     β”œβ”€ arrow-cpp [10.0.1|11.0.0|8.0.0] would require
β”‚  β”‚     β”‚     β”‚  └─ python >=3.10,<3.11.0a0 , which can be installed;
β”‚  β”‚     β”‚     β”œβ”€ arrow-cpp [10.0.1|11.0.0|8.0.0] would require
β”‚  β”‚     β”‚     β”‚  └─ python >=3.8,<3.9.0a0 , which can be installed;
β”‚  β”‚     β”‚     └─ arrow-cpp [10.0.1|11.0.0|8.0.0] would require
β”‚  β”‚     β”‚        └─ python >=3.9,<3.10.0a0 , which can be installed;
β”‚  β”‚     └─ pyarrow 8.0.0 would require
β”‚  β”‚        └─ arrow-cpp >=8.0.0,<8.0.1.0a0  with the potential options
β”‚  β”‚           β”œβ”€ arrow-cpp [10.0.1|11.0.0|8.0.0|8.0.1|9.0.0], which cannot be installed (as previously explained);
β”‚  β”‚           β”œβ”€ arrow-cpp [10.0.1|11.0.0|8.0.0], which can be installed (as previously explained);
β”‚  β”‚           β”œβ”€ arrow-cpp [10.0.1|11.0.0|8.0.0], which can be installed (as previously explained);
β”‚  β”‚           β”œβ”€ arrow-cpp [10.0.1|11.0.0|8.0.0], which can be installed (as previously explained);
β”‚  β”‚           └─ arrow-cpp 8.0.0 would require
β”‚  β”‚              └─ python >=3.7,<3.8.0a0  with the potential options
β”‚  β”‚                 β”œβ”€ python [3.7.0|3.7.1|...|3.7.9], which can be installed;
β”‚  β”‚                 └─ python [3.6.7|3.7.1], which cannot be installed (as previously explained);
β”‚  β”œβ”€ datasets [2.10.1|2.12.0|2.6.1] would require
β”‚  β”‚  └─ python >=3.10,<3.11.0a0 , which can be installed;
β”‚  β”œβ”€ datasets [2.10.1|2.12.0|2.6.1] would require
β”‚  β”‚  └─ python >=3.8,<3.9.0a0 , which can be installed;
β”‚  β”œβ”€ datasets [2.10.1|2.12.0|2.6.1] would require
β”‚  β”‚  └─ python >=3.9,<3.10.0a0 , which can be installed;
β”‚  └─ datasets 2.6.1 would require
β”‚     └─ python >=3.7,<3.8.0a0  with the potential options
β”‚        β”œβ”€ python [3.7.0|3.7.1|...|3.7.9], which can be installed;
β”‚        └─ python [3.6.7|3.7.1], which cannot be installed (as previously explained);
β”œβ”€ grpcio 1.54.3.*  is installable with the potential options
β”‚  β”œβ”€ grpcio 1.54.3 would require
β”‚  β”‚  └─ libgrpc 1.54.3 hfaa49da_0, which conflicts with any installable versions previously reported;
β”‚  β”œβ”€ grpcio 1.54.3 would require
β”‚  β”‚  └─ python >=3.10,<3.11.0a0 , which can be installed;
β”‚  β”œβ”€ grpcio 1.54.3 would require
β”‚  β”‚  └─ python >=3.8,<3.9.0a0 , which can be installed;
β”‚  └─ grpcio 1.54.3 would require
β”‚     └─ python >=3.9,<3.10.0a0 , which can be installed;
β”œβ”€ langchain is installable with the potential options
β”‚  β”œβ”€ langchain [0.1.0|0.1.1|0.1.2|0.1.4] would require
β”‚  β”‚  └─ datasets >=2.15.0,<3.0.0 , which conflicts with any installable versions previously reported;
β”‚  β”œβ”€ langchain [0.0.136|0.0.142|...|0.0.298] would require
β”‚  β”‚  └─ networkx >=2.6.3,<3.0.0 , which can be installed;
β”‚  └─ langchain [0.0.299|0.0.300|...|0.0.354] would require
β”‚     └─ anyio <4.0  with the potential options
β”‚        β”œβ”€ anyio [2.0.2|2.1.0|...|3.3.2] would require
β”‚        β”‚  └─ python >=3.6,<3.7.0a0  with the potential options
β”‚        β”‚     β”œβ”€ python [3.6.7|3.7.1], which cannot be installed (as previously explained);
β”‚        β”‚     └─ python [3.6.0|3.6.1|...|3.6.9], which can be installed;
β”‚        β”œβ”€ anyio [2.0.2|2.1.0|...|3.6.1] would require
β”‚        β”‚  └─ python >=3.7,<3.8.0a0  with the potential options
β”‚        β”‚     β”œβ”€ python [3.7.0|3.7.1|...|3.7.9], which can be installed;
β”‚        β”‚     └─ python [3.6.7|3.7.1], which cannot be installed (as previously explained);
β”‚        β”œβ”€ anyio [2.0.2|2.1.0|...|3.6.1] would require
β”‚        β”‚  └─ python >=3.8,<3.9.0a0 , which can be installed;
β”‚        β”œβ”€ anyio [2.0.2|2.1.0|...|3.6.1] would require
β”‚        β”‚  └─ python >=3.9,<3.10.0a0 , which can be installed;
β”‚        β”œβ”€ anyio [2.2.0|3.3.4|3.4.0|3.5.0|3.6.1] would require
β”‚        β”‚  └─ python >=3.10,<3.11.0a0 , which can be installed;
β”‚        └─ anyio [1.0.0|1.2.2|...|3.7.1] conflicts with any installable versions previously reported;
β”œβ”€ libabseil 20230125.3.*  is not installable because it conflicts with any installable versions previously reported;
β”œβ”€ networkx 2.6.2.*  is not installable because it conflicts with any installable versions previously reported;
└─ pin-1 is not installable because it requires
   └─ python 3.11.* , which conflicts with any installable versions previously reported.

Pins seem to be involved in the conflict. Currently pinned specs:
 - python 3.11.* (labeled as 'pin-1')