Can't add credentials on Render and Hugginface

Hi Everyone ,
First of all I want to give you a special thanks for this amazing tool , it’s like a dream come true for non-developers like me.
Here is the situation :
I installed everything according to the documentation in Render first then on Huggingface , I can pretty much do anything with Flowise on both flowise and huggingface except for one thing , which is adding a credential , as you can see in the picture you can even get the suggestions for the API keys to be added all what I get is this white empty window , also I also tried to add the credentials directly from the chatflows it’s the same problem. please help it’s for an emergency project.
I analysed my log this found out this error somehow its connected to upstash redis, and yet doesnt not exlain the credential problem.
This is the error code : 2024-01-16 10:26:18 [ERROR]: :x: [server]: Error during Data Source initialization: require() of ES Module /usr/src/packages/node_modules/@upstash/redis/nodejs.mjs not supported.
Error [ERR_REQUIRE_ESM]: require() of ES Module /usr/src/packages/node_modules/@upstash/redis/nodejs.mjs not supported.


Pull the latest version from Github and update. I had this same problem with 1.4.9, but updating to 1.4.10 yesterday fixed it for me. Good luck!

1 Like