Delete organizations / models from the Hub

I have made a few mistakes while uploading my model. In particular:

  1. I uploaded it under my own name instead of the organization’s
  2. I made a typo in the organization’s name

I have since created a new organization with the correct name and uploaded the models there, but now I am a member of two almost identical organizations and the model is in two separate places on S3 (under my and my organization’s namespaces). Is there a way to delete them?

I think you have to ask nicely to @julien-c

Thanks! How do I reach him?

OK, so I managed to delete the model under my name with transformers-cli s3 rm. All that remains is the organization.

I tagged him here, should be enough :wink:

1 Like

Hi @DavidNemeskey, which user/organization should we delete? (we don’t have an automated way but I can do it manually)

The one without any models and the I: SZTAK-HLT.

Thanks!

Done, thanks for reporting

Thanks (for fixing & merging the PR as well).

Hello @julien-c,
I am having the same problem, would you kindly delete the model named EstBERT under my account.

thank you very very much!

The models you can delete yourself, using transformers-cli s3 rm.

(You have to do it file by file, if I remember correctly)

For convenience I’ve deleted your model.

I actually tried deleting the whole repo/ folder and did not work, so it has to be file-wise.

However, thank you very very much :))

Hi @julien-c,
I’ve created this account and this organization which are confusing since they are supposed to refer to the same organization. And, I couldn’t delete them or change their usernames or remove their connection to each other. Would you mind if I ask for your help to remove both of these account/organization so that I can create a proper one?

Also, may I kindly ask for your help to remove the dataset boun-tabi/nli_tr as well? I’ve tried removing it by executing transformers-cli s3 rm for each file that I know of but it looks like there are more files that are not visible to me.

Your help is very much appreciated.

1 Like

Hi @e-budur, I’ve deleted the account and the organization, and also deleted your dataset from the bucket.

The only remaining user account is https://huggingface.co/e-budur

Thank you so much @julien-c :+1:

Hi @julien-c,

A while ago I uploaded some models that my organization wanted to share publicly. However, I initially made a mistake and created a repo under my own username instead of that of my organization (here). For clarity, I would like to delete this repo completely (I managed to delete all the files contained using transformers-cli).

Could you let me know if there is a way to achieve this? (or do it in my behalf if it is currently not possible?). Thank you very much for any help!

@joangines done. We’ll expose some UI to do this in the future

Thank you very much :slight_smile:

Hi @julien-c,
I just created my personal account but used the username of my organization. Is it possible to change the username to something else? Or could you kindly help me delete my account? I’ll start over and sign-up with the correct information again. Thank you very much for any help!

Sure – I just deleted user laboro-ai, feel free to start over!