Error message when building repository

Hello all,

I’ve tried to build my repository but am receiving this error message:

--> FROM
DONE 0.0s

--> RUN useradd -m -u 1000 user

--> RUN sed -i 's g' /etc/apt/sources.list && sed -i 's g' /etc/apt/sources.list && sed -i '/security/d' /etc/apt/sources.list && apt-get update && apt-get install -y 	git 	git-lfs 	ffmpeg 	libsm6 	libxext6 	cmake 	libgl1-mesa-glx 	&& rm -rf /var/lib/apt/lists/* 	&& git lfs install

--> RUN --mount=target=/root/packages.txt,source=packages.txt 	sed -i 's g' /etc/apt/sources.list && sed -i 's g' /etc/apt/sources.list && sed -i '/security/d' /etc/apt/sources.list && apt-get update &&     xargs -r -a /root/packages.txt apt-get install -y     && rm -rf /var/lib/apt/lists/*

--> RUN pip install --no-cache-dir pip==22.3.1 &&     pip install --no-cache-dir         datasets         "huggingface-hub>=0.12.1" "protobuf<4" "click<8.1"

--> WORKDIR /home/user/app

--> RUN --mount=target=pre-requirements.txt,source=pre-requirements.txt 	pip install --no-cache-dir -r pre-requirements.txt

--> ERROR: process "/bin/sh -c git init  && git remote add origin $(cat /run/secrets/SPACE_REPOSITORY)  && git add --all  && git config \"\"  && git config \"Name\"  && git commit -m \"lfs\"  && git lfs pull  && rm -rf .git .gitattributes" did not complete successfully: exit code: 2

Does anyone know what this error message means? Seems like there’s something wrong with the credentials.
Also, what I find kind of odd is that it is mentioning python version 3.8.9 when I’ve defined python>=3.9 in my setup py.

I also get the same error. Did you happen to fix it. please let me know