Space in permanent building state, no logs

Hello there,

I have pushed a Gradio app to one of my spaces and it’s being Building for a while (more than 20 minutes). All I see in the Build screen is:

Error: Failed to load logs: Not Found. Logs are persisted for 30 days after the Space stops running.

The space files are here: aagirre92/foodvision_big at main

On top of that, I have another space that was working fine (but now it is not even loading…)

Any tips? Tried the factory reboot but same result…

Thanks a lot

It seems most spaces can’t be built right now, when an actual error shows it says:

Runtime error

Scheduling failure: not enough hardware capacity

Perhaps the lucky ones are those that were built in the time where some hardware capacity was available for them (I’d tell you to try going to settings and clicking on Factory Reboot, but that may only show these errors instead of being stuck building, not that the space would build.)

Where did you check that? Thanks a lot!

I just kept hitting Factory Reboot in settings until the errors were shown instead of being stuck building with no logs found.
About 15 minutes after my other message everything went back to normal, you should be able to build a space without problems now.