Trouble building space, missing rust for tokenizers

My space CLIP Interrogator - a Hugging Face Space by pharma seems to have died yesterday and restart and factory reboot fails as it tries installing the tokenizers dependency and fails with missing rust compiler.

Building wheel for tokenizers (pyproject.toml) did not run successfully.
error: can't find Rust compiler

Is this from a change to base image spaces use or something? I’ve tired pinning and rolling back to some older versions of the requirements but without success so far.

hi @pharma ,
we’ve recently changed the default Python on Spaces to 3.10, not sure why the rust issue now, however we can rollback the Python version to 3.9 on your Space and it sees to fix the issue
I send you a PR

1 Like

Thank you! Yes that fixes it.

1 Like

Same issue! New here so forgive me but

running build_rust
error: can’t find Rust compiler

Failed to build tokenizers
ERROR: Could not build wheels for tokenizers, which is required to install pyproject.toml-based projects

hi @Papajams please try changing the python version on the

e.g. python_version: 3.9.13

hello! thanks for coming back to me. That doesn’t seem to work sadly, would have loved such a simple solution. Metaphorize - a Hugging Face Space by Papajams

Does it matter what python version I am running on my own computer? I downgraded from 3.11 to 3.8 and still no dice on hugging faces spaces. Appreciate your guidance!

@radames I encountered this issue as well in
I already tried downgrading the python_version to the following versions but getting an issue with building wheel for pandas:

  • 3.9.13
  • 3.8.17
  • 3.8.13
  • 3.7.17

Anybody resolve this issue?

are you having this issue with CLIP Interrogator? Could you please share a public Space, thanks