Why can't I upload a parquet file to my dataset? (Error: o?.throwIfAborted is not a function.)

I want to upload a parquet file to my hugging face dataset. When I drag and drop it into the “Upload file(s)” area and click “Commit changes to main” I get the following error:

Error: o?.throwIfAborted is not a function. (In ‘o?.throwIfAborted()’, ‘o?.throwIfAborted’ is undefined)

This surprises me as the parquet file does not seem to be dysfunctional or bugged - when I run

df = pd.read_parquet('test.parquet')    

in python the code prints my data inside the parquet file … so the file does not seem to be the problem here. However I can’t upload it to my hugging face dataset - does somebody have a clue why that is and how to fix it?


I was trying to upload my parquet file to huggingface using safari as a browser. It worked out yesterday (using safari) when I uploaded a parquet file. Today I tried to upload another parquet file but got the above error.

After searching online about the error I found out that the method throwIfAborted() comes from Web APIs. Immediately I knew that it could be caused by the browser. Tried uploading my parquet file again - this time using chrome as a browser. Worked.

We’ve deployed a fix for uploading with Safari. If you get this error again, please let us know.


Tried it again today using Safari. This time I wanted to upload 16 parquet files at once. I got the following error:

Error: t.at is not a function. (In ‘t.at(-2)’, ‘t.at’ is undefined)

I thought I’d let you know since you’ve asked me to.

When I’ve tried to upload those exact same 16 parquet files with Chrome afterwards it worked without a problem - so I assume it was an issue with the browser again.

Updating the OS (to update Safari) should fix this issue.

1 Like

I’m sorry I should have added more info:

Was using Safari Version 14.1.2 on a 10.15.7 MacOS Catalina. I guess with a newer OS it works without a problem. :+1:

1 Like

The compatibility table for Array.at() to get the minimum version (15.4 for Safari):