Build Error - Bad Request

Hi - I am seeing an unexpected “Bad Request” build error without any explanation, even when I switch to paid hardware for my spaces. All spaces that have already been built seem to be working fine even on the free hardware tier. It’s been happening throughout the past 16 hours or so for me. Is anyone else seeing this with their spaces?

hi @vamsi-tetali , we had some internal issues solved now, could you please try again?

Thank you, @radames. Just tried but still seeing the issue in the two spaces I tried.

ok, we had some build queue issue earlier, solved now. Maybe you Bad Request” is another issue, could you share your Space?

It looks like mine is related to using a private model through a huggingface access token. Below is the error:

Traceback (most recent call last):
  File "", line 25, in <module>
    model = SentenceTransformer('synente/nli-distilroberta-base-v2finetuned_model_jan2', use_auth_token=hf_access_token)
  File "/home/user/.local/lib/python3.8/site-packages/sentence_transformers/", line 87, in __init__
  File "/home/user/.local/lib/python3.8/site-packages/sentence_transformers/", line 491, in snapshot_download
    path = cached_download(**cached_download_args)
  File "/home/user/.local/lib/python3.8/site-packages/huggingface_hub/utils/", line 124, in _inner_fn
    return fn(*args, **kwargs)
  File "/home/user/.local/lib/python3.8/site-packages/huggingface_hub/", line 778, in cached_download
  File "/home/user/.local/lib/python3.8/site-packages/huggingface_hub/", line 512, in http_get
  File "/home/user/.local/lib/python3.8/site-packages/huggingface_hub/utils/", line 314, in hf_raise_for_status
    raise BadRequestError(message, response=response) from e

Bad request:

The space’s name is synente/description_split_and_match. It is a private space and the model being accessed is also a private model.

hi @vamsi-tetali

could you please try again?

1 Like

Worked this time. Thank you!

1 Like