Huggingface "can't find space"

What could be causing this error?

import gradio as gr
with gr.Blocks() as b:

Can you try a factory reboot? I just duplicated your space and it’s working well for me!

1 Like

Factory reboot did not work.
Duplicating the Space as “Public” allows the iframe to work.
Duplicating the Space as “Private” prevents the iframe from working both as Private, and when set to Public.

Building a Space as Public works.
Building a Space as Private and then setting it to Public prevents the iframe from working.

This problem is new in the past 24 hrs.

Based on some testing, Spaces that are built in “Private” are unable to be found when set to “Public”.
Factory rebooting doesn’t fix it when set to Private or Public.

This problem developed within the past 24 hrs.


Hi, these spaces are still not working. Is there an update on what caused this suddenly?

I just built this space in Private and then set it to Public, and the iframe is “not found”.

Has the source of this problem been discovered?
Is there a solution in the works?
Is this type of information posted somewhere?

hi @xp3857 , I just forked your test and it works fine
Can you please try a Factory Reboot and tell us what do you get? We had a infra migration happening a few days ago. thanks

I just factory rebooted it again, you can see if it worked by clicking the link to the iframe. I have found a different route to resolution however, so we don’t need to troubleshoot this for any more days. Thanks!

OK great, I see you have many other spaces that work fine.

Is there an acceptable ratio of working to non-working spaces per account?

I’m not sure about that. A working Space app might depend on its implementation, and building apps that depend on other Spaces could cause additional issues. Remember, we recently migrated our Spaces infra, and a factory reboot might help resolve any issues