Streamlit Space Stuck on "Building"

Hello. I’m working on a space to show dataset statistics for the BigBIO working group (bigbio (BigScience Biomedical Datasets)).

I’ve tested the code locally and on the streamlit cloud and both run without problems.

However, the HF spaces version (Bbtest - a Hugging Face Space by gabrielaltay) appears to reach the end of the build process,

#10000 ===== Application Startup at 2023-01-21 21:24:56 =====

2023-01-21 22:25:33.987 INFO    matplotlib.font_manager: generated new fontManager

Collecting usage statistics. To deactivate, set browser.gatherUsageStats to False.

2023-01-21 22:25:55.575 Did not auto detect external IP.
Please go to https://docs.streamlit.io/ for debugging hints.

  You can now view your Streamlit app in your browser.

  Network URL: http://10.19.19.179:8501

but the space is stuck in a state of “Building”. I’ve tried factory reset a few times but get the same results. there is something I’d like to check but cant w/o access to the host machine,

  • I put git+https://github.com/bigscience-workshop/biomedical.git in the requirements.txt file to have access to the bigbio Python package. There are some dataloading scripts that are treated as data there (biomedical/setup.cfg at main · bigscience-workshop/biomedical · GitHub) … I’m curious to know if those dataloading scripts are actually making there way to the pip installation (I can see them locally in the site_packages directory and they must be there in the streamlit cloud for it to work, but maybe the way the HF space pip installs is different?)

In addition

  • I have some print statements in the early part of the app.py file that I don’t see in the hugging face spaces log, I’ll turn these into real logging statements and see if that helps.
  • I pinned streamlit==1.17.0 in requirements, but I’ve tried with and w/o this with the same results.

Any debugging ideas appreciated!

1 Like

Thanks for the comment, I was going through Gradio releases to find one that worked. None worked. Pretty sure the issue is on the server side.

I’m also seeing my streamlit spaces stuck in “building”. I tried a simple hello-world example, and I tried restarting, factory resetting, and creating a new space without success.

I suffer this problem too

hi all, were experiencing some infra outages this weekend

sorry to hear that! thanks for the heads up. fwiw, the space is building now.

1 Like