App in Spaces takes forever in "Building"

I made an app using Streamlit. Everything works fine in my local folder, but in Spaces, it is always in “Building” state. I’ve tried Restart Space a few times and still have the same issue. The last part of the log is as follows. Could anyone suggest how to fix it? Thank you.
→ Pushing image
DONE 3.6s
→ Exporting cache
DONE 2.6s
===== Application Startup at 2023-05-07 01:36:40 =====
Collecting usage statistics. To deactivate, set browser.gatherUsageStats to False.
You can now view your Streamlit app in your browser.
Network URL:
2023-05-07 03:38:52.298 Did not auto detect external IP.
Please go to for debugging hints.

I was disappointment about this yesterday but could not get it to work no matter what I tried. Today I restarted the space and it works! Really I did not do anything and I am not sure why …

Same issue.
Container logs show:

Running on local URL:

But App shows “Building” forever.
Restarted the space a couple of time. But same issue.
Any fix?

Same thing happening to me too :frowning: