Build Error - no log?!

Hi,
I’m trying to upload my app on Spaces.
This app built with gradio works on my computer but I have a build error without any explanation (no log).
So I’m interested if anyone knows something about this issue.
Thanks in advance
https://huggingface.co/spaces/mikachou/dog-breed-detection

Finally I have a “ValueError: bad marshal data (unknown type code)”

due to the fact that I have trained my model with tf on python 3.7 (Google colab) and the execution environment is in python 3.8
(it works at home with pyenv and python 3.7)
thanks

hi @mikachou I see you’re now using the python_version parameter
Did you succeed running your project?

Hi,

Sorry for late answer.

I put python_version parameter, it worked yesterday.

But today I changed some files in project, and parameters in README.md.
I also changes the space url from /dog-breed-detection to /dog-breed-identification.
Anyway it stopped working.

For today I’ve always had the same message :

Build error
build failed with exit code: 1, message: None

with no log

My app works on local machine. Please help me!

Thanks in advance.

sorry @mikacho, it seems like we’re having issues on our infra, which is affecting Spaces. You could try a factory reboot meanwhile.

no pb,
I already tried factory reboot many times, I will try it again.
keep finger croosed :crossed_fingers: hope it will work

OK I’ve just tried factory reboot again twice, each time after a few second I’ve had the problem : build error, message:None, no logs

@radames
OK I made many factory reboot, and I’ve just done another one earlier this morning and this one finally worked.
Is this case (build error; message: None; no log) likely to occur again in future?
Thank you

Issue were linked to an outage on an underlying service of the space build process. The build error case with no logs is not supposed to happen in the nominal cases.

1 Like

@chris-rannou thanks for answer
I hope it won’t happen again :crossed_fingers:
I would like to make later further modifications on code but now I fear a bit about deployments :grimacing:
I’ll do the modifications another time.
Thanks