Cannot upload large files for a single repository

So I have created four model repositories. I have followed the same steps for each one.
Create model repository HF website
Login to HF Hub from terminal on server
Clone repository to my server.
Enable large files
Create quant with final destination the local clone of repository
git add
git commit
git push
Worked flawlessly twice
Third one gives me

remote: Your push was rejected because it contains files larger than 10 MiB.
remote: Please use to store large files.
remote: See also:
remote: Offending files:
remote:   - tokenizer.json (ref: refs/heads/main)
remote: -------------------------------------------------------------------------
To <my HF https repository URL>
 ! [remote rejected] main -> main (pre-receive hook declined)
error: failed to push some refs to <my HF https repository URL>

I created a fourth repository and made a quant for another model and went through the steps to make sure I wasn’t crazy. The fourth one worked like a champ.
I have tried.
-Delete repository on HF and create a new one with a different name. Clone to local server and copy all the files to the new destination. - Same issue

  • Try to commit a different 10MB+ file - they all fail. Files less than 10MB are fine
    And yes I am doing
    git lfs install
    and also
    huggingface-cli lfs-enable-largefiles .
    Thanks in advance!

Just had another successful upload of about 100GB to a repo but not with the folder in question. A new one. I don’t freaking get it