Receiving this error even with a new space

Hi, I’ve created a space today and everything was working fine. Suddenly i’ve started to receive this error on all spaces i create:
===== Build Queued at 2023-06-14 22:21:57 / Commit SHA: 7d6f0c5 =====

→ FROM Docker
DONE 5.7s

DONE 5.8s

→ RUN sed -i 's
(had to remove due to only 2 links allowed)

‘/security/d’ /etc/apt/sources.list && apt-get update && apt-get install -y git git-lfs ffmpeg libsm6 libxext6 cmake libgl1-mesa-glx && rm -rf /var/lib/apt/lists/* && git lfs install
sed: can’t read /etc/apt/sources.list: No such file or directory

1 Like


I am encountering exactly the same problem. Seems to be the underlying gradio containers.

hi currently there is an error using the default Python 3.10 container, please switch to Python 3.9.13. On the Space you can change the Python version by adding this line

python_version: 3.9.13

@diogovelho here is my PR on your shared Space.


Thanks a lot. It solved it but missing python 3.10. Hope. it can be fixed soon

1 Like

thank you.

I have changed the but the problem is still there for me.
Any ideas? Thank you.

colorFrom: pink colorTo: purple

python_version: 3.9.13

the underlying issue should be fixed now, thus you can get back to Python 3.10. thanks for your patience

Hi, community

how can I fix this error code on my Space Repo - sed: can’t read /etc/apt/sources.list: No such file or directory

snapshot Below


hi @mrprycep069 can you please try factory reboot? this issue should be fixed now

@radames Thank you its worked

1 Like

Hey I am having the same issue… I will switch to phyton. thankyou.

I am facing the same issue in building a space

I have the same issue as @bhnvgoyal, changing the Python version to 3.9 in and factory rebooting does not seem to work

Seems wide-spread…

Now I’m getting the python build error -

I had a similar problem on one of my Spaces and reverting back to python 3.9.13 fro 3.10 still corrected the issue (the issue occurred on 7/7/2023).